June 14, 2007

Warning on WordPress 2.2

0 Flares Twitter 0 Facebook 0 Google+ 0 Email -- 0 Flares ×

I installed WordPress 2.2 on June 12. Added some new posts. Everything seemed to be going well. Until last night. I had some issues around the house (yay toilet leaks) and blogged about it. While I was in the middle of writing the post, the SQL database got corrupted. WordPress threw an error message that prompted me to install.

Everything I tried — restoring the database from backup and upgrading from 2.1.2 to 2.2 again — failed. My host just restored all of my files to June 11, just prior to the wordpress update.

I’ve been using WordPress for three years and have never had any trouble with it. On an interesting note, my host said that this is the third SQL database corruption they have had with WP in the past week. Apparently this is the first time they have had any trouble with WordPress.

I’m not sure if the problems I saw were caused by WordPress or a glitch in the server. I’m not going to take a chance at this rate. I’m going to just stay with WP 2.1.2 until either the next bugfix comes out or 2.3 has been out for a while.

0 Flares Twitter 0 Facebook 0 Google+ 0 Email -- 0 Flares ×

Leave a Reply